Printing not working - 500 error

Description

From the View Requisitions (as an administrator) I went to this requisition and selected print and received the following error at this URL:
https://test.openlmis.org/api/requisitions/89bd3422-9ada-4369-8ee3-5747fa79c92d/print?access_token=dd8556cf-996e-4525-b9df-ed293dfdcd81

Environment

None

Activity

Show:
Lucyna Laska
July 11, 2017, 6:38 AM

I can't print the requisition. I have tried to print the requisitions initiated by user or from demo-data. The error is still returned (the same as the one showed on the attached screenshot). Could you please take a look on that?

Paweł Nawrocki
July 11, 2017, 11:53 AM

That's because test server environment was still using older requisition service version (4.0.1-SNAPSHOT instead of 5.0.0-SNAPSHOT), so it did not have the latest changes. Updated the test deployment script and rebuilt - please re-test.

Lucyna Laska
July 11, 2017, 12:32 PM

Okay, so after retesting I noticed that now it's possible to print the requisition.

I assigned the ticket to you. In my opinion, the bug is done but you can test it out and confirm that. During testing, I also found a bug which was reported in the ticket OLMIS-2838.

Paweł Albecki
July 11, 2017, 3:38 PM
Edited

It was caused by reduction fields in requisition line items dto (for performance). Orderables refactor was 2 months ago and reports were working good after refactor.

Mary Jo Kochendorfer
July 13, 2017, 4:50 PM

, thank you for commenting on the RCA of the bug. FYI . I just tested and it looks like it is working. Thank you.

Done

Assignee

Paweł Albecki

Reporter

Mary Jo Kochendorfer

Labels

Story Points

2

Time tracking

0m

Time remaining

0m

Components

Sprint

None

Fix versions

Priority

Critical