During the QA on suggests that I should change POD endpoints name from proofOfDeliveries to proofsOfDelivery because "Proof of Delivery" is the correct form - it's a proof of one delivery, not of multiple ones.
We should stay consistent with everything else like model, db schema, etc.
rename endpoints to proofsOfDelivery
renamed model, db schema, etc.
modify the UI to use new endpoint names