Users with home facility rights don't get a notification about nonfunctional CCE

Description

Steps to Reproduce
1. Follow all steps in (log in as "rivo", navigate to CCE Management > CCE Inventory, click Search to search at home facility, Depósito Provincial Niassa with EPI program)
2. Click edit on a CCE inventory item that is already functioning, such as Fridge #12. Change functionality status to "Awaiting Repair" or "Unserviceable". Choose a reason and, if prompted, a decommission date.
3. Click Update to save your changes.
4. No email sent for any user

Root cause:
Rivo can't receive notification about non functioning inventory because there is no CCE facility in Requisition Group for any supervisory node.
This error can impact other users that have home facility not associated with any supervisory node (by requisition groups).

Acceptance criteria:

  • users that have home-facility rights (CCE_INVENTORY_EDIT, for CCE program) should receive notifications too and those right assignments don't have supervisory nodes.

Environment

None

Assignee

Łukasz Lewczyński

Reporter

Paweł Albecki

Labels

Story Points

2

Time tracking

24h

Epic Link

Sprint

None

Affects versions

Priority

Major
Configure