We're updating the issue view to help you get more done. 

Modify reporting docker-compose to install Postgres library and use latest custom version of NiFi

Description

The NiFi Dockerfile does not include a Postgres DBCP library, to connect to Postgres databases this is a requirement.

Additionally, we've made recent changes to the OAuth processor in NiFi, these won't be released until the next NiFi release or after, to use them we'll have to use a more recent version of the NiFi source code.

To accommodate the above, we need to modify our docker-compose script to

  • install the Postgres driver

  • use an unreleased version of the code that includes our OAuth processor changes

If there is a way to do this without forking releasing a custom NiFi Dockerfile that is highly preferred, because the NiFi community is very active and keeps their containers up to date with their latest release.

Status

Assignee

Jason Rogena

Reporter

Peter Lubell-Doughtie

Labels

None

Epic Link

Components

Sprint

None

Priority

Major