Issues with notifications on the Orderable Details screen

Description

During exploratory tests, I noticed that after updating a product on the "Orderable Details" screen, an incorrect notification occurs. Also, when trying to save changes with e.g. blank "Quantity" field, the notification that the update failed doesn't occur - there is no notification at all but the invalid form modal.

Reproduction steps:

  1. Log into the application as administrator.

  2. Navigate to Administration > Products.

  3. Click the "View" link next to any product.

  4. Click the "Create Kit Unpack List" button.

  5. Add any product without entering the quantity.

  6. Click the "Save Kit Unpack List" button.

  7. The "This form is invalid" modal occurs without the notification that the update failed.

  8. Enter any quantity for the product.

  9. Click the "Save Kit Unpack List" button and confirm.

  10. The "Product saved successfully" notification occurs.

Expected results:

  1. When the update is successful, the following notification should appear: "The product was updated successfully!";

  2. When the update fails, the following notification should appear: "Failed to update the product!".

Environment

None

Activity

Show:
Adugna Worku
March 30, 2019, 10:00 AM

While saving the products, the following are the notifications when -

  • The form is valid but there is server side problem: "Failed to update the product!"

  • The product is saved successfully : "The product was updated successfully!"

  • The form has error : "This form is invalid" (please refer the other forms e.g Facility)

Joanna Szymańska
April 11, 2019, 8:51 AM

I tested this ticket and the notifications are correct.

Assignee

Adugna Worku

Reporter

Joanna Bebak

Labels

None

Story Points

2

Time tracking

30m

Epic Link

Components

Sprint

None

Fix versions

Priority

Major
Configure