Currently, in orderable and FTAP resources we have the versionId field but because of discussion on the forum the field should be renamed to versionNumber.
The versionId query parameter in endpoints should be renamed to versionNumber.
In the code, all occurrence of versionId should be renamed to versionNumber.
domain classes, repository, DTO classes, RAML, etc.
Same should be done in database tables
please remember about updating
the versionNumber field should be present as a number in DTOs